railsアプリのrubyを2.4.0にアップデート

簡単な家計簿アプリのrubyを2.4.0にアップデートした。

環境

  • ruby(old) 2.3.1
  • rails 5.0.0.1

手順

rubyのバージョンは Gemfile と .ruby-version に記載しているのその2つを書き換える

bundle install がjson gemでこける

bundle installでjson gem 1.8.3が失敗する。
ruby2.4.0で数字の扱いが変わったのでそれが原因かも。
この1.8.3はrailsの依存なので、railsをアップデート。

# 以下はローカルのMAC作業環境
$ bundle update

rails 5.0.1 にあがり依存するjson gemが2.0.2となりました。
無事起動を確認しherokuにpush。
herokuが2.4.0に対応してた。早い。

Pocket

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です