CentOSでapacheを5.3.3から5.4に

owncloudを入れたら、セキュリティ警告がでたのでちょっと試しに上げてみることにした。

ここを参考にしました。

レポジトリ?の追加

$ wget http://dl.iuscommunity.org/pub/ius/stable/Redhat/6/x86_64/ius-release-1.0-11.ius.el6.noarch.rpm
wget http://dl.iuscommunity.org/pub/ius/stable/Redhat/6/x86_64/epel-release-6-5.noarch.rpm

rpmする

$ sudo rpm -ivh epel-release-6-5.noarch.rpm ius-release-1.0-11.ius.el6.noarch.rpm
警告: epel-release-6-5.noarch.rpm: ヘッダ V4 DSA/SHA1 Signature, key ID 9cd4953f: NOKEY
準備中... ########################################### [100%]
パッケージ epel-release-6-8.noarch (epel-release-6-5.noarch より新しいもの) は既にインストールされています。
#すでに入ってたっぽいです。
$ sudo rpm -ivh ius-release-1.0-11.ius.el6.noarch.rpm警告: ius-release-1.0-11.ius.el6.noarch.rpm: ヘッダ V4 DSA/SHA1 Signature, key ID 9cd4953f: NOKEY
準備中... ########################################### [100%]
1:ius-release ########################################### [100%]
入ってるPHP系の確認、なんかやたらあるね。
$ rpm -qa |grep php
php-php-gettext-1.0.11-3.el6.noarch
php-pdo-5.3.3-23.el6_4.x86_64
php-mbstring-5.3.3-23.el6_4.x86_64
php-pear-1.9.4-4.el6.noarch
php-process-5.3.3-23.el6_4.x86_64
php-common-5.3.3-23.el6_4.x86_64
php-cli-5.3.3-23.el6_4.x86_64
php-mysql-5.3.3-23.el6_4.x86_64
php-gd-5.3.3-23.el6_4.x86_64
php-pear-Net-Curl-1.2.5-4.el6.noarch
php-pear-MDB2-Driver-mysqli-1.5.0-0.8.b4.el6.noarch
php-mcrypt-5.3.3-1.el6.x86_64
php-5.3.3-23.el6_4.x86_64
phpMyAdmin-3.5.8.1-1.el6.noarch
php-pear-MDB2-2.5.0-0.9.b5.el6.noarch
php-xml-5.3.3-23.el6_4.x86_64
片っ端から消し
$ sudo yum erase php-php-gettext php-pdo php-mbstring php-pear php-process php-common php-cli php-mysql php-gd php-pear-Net-Curl php-pear-MDB2-Driver-mysqli php-mcrypt php phpMyAdmin php-pear-MDB2 php-xml
Loaded plugins: fastestmirror, security
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.3-23.el6_4 will be erased
--> Processing Dependency: php for package: owncloud-5.0.12-12.1.noarch
---> Package php-cli.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package php-common.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package php-gd.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package php-mbstring.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6 will be erased
---> Package php-mysql.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package php-pdo.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package php-pear.noarch 1:1.9.4-4.el6 will be erased
---> Package php-pear-MDB2.noarch 0:2.5.0-0.9.b5.el6 will be erased
---> Package php-pear-MDB2-Driver-mysqli.noarch 0:1.5.0-0.8.b4.el6 will be erased
---> Package php-pear-Net-Curl.noarch 0:1.2.5-4.el6 will be erased
---> Package php-php-gettext.noarch 0:1.0.11-3.el6 will be erased
---> Package php-process.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package php-xml.x86_64 0:5.3.3-23.el6_4 will be erased
---> Package phpMyAdmin.noarch 0:3.5.8.1-1.el6 will be erased
--> Running transaction check
---> Package owncloud.noarch 0:5.0.12-12.1 will be erased
--> Processing Dependency: owncloud = 5.0.12 for package: owncloud-3rdparty-5.0.12-12.1.noarch
--> Running transaction check
---> Package owncloud-3rdparty.noarch 0:5.0.12-12.1 will be erased
--> Finished Dependency Resolution
ius | 2.2 kB 00:00
ius/primary_db | 109 kB 00:00
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Removing:
php x86_64 5.3.3-23.el6_4 @updates 3.5 M
php-cli x86_64 5.3.3-23.el6_4 @updates 6.2 M
php-common x86_64 5.3.3-23.el6_4 @updates 2.9 M
php-gd x86_64 5.3.3-23.el6_4 @updates 324 k
php-mbstring x86_64 5.3.3-23.el6_4 @updates 2.1 M
php-mcrypt x86_64 5.3.3-1.el6 @epel 46 k
php-mysql x86_64 5.3.3-23.el6_4 @updates 216 k
php-pdo x86_64 5.3.3-23.el6_4 @updates 168 k
php-pear noarch 1:1.9.4-4.el6 @base 2.2 M
php-pear-MDB2 noarch 2.5.0-0.9.b5.el6 @epel 804 k
php-pear-MDB2-Driver-mysqli
noarch 1.5.0-0.8.b4.el6 @epel 251 k
php-pear-Net-Curl noarch 1.2.5-4.el6 @epel 30 k
php-php-gettext noarch 1.0.11-3.el6 @epel 57 k
php-process x86_64 5.3.3-23.el6_4 @updates 65 k
php-xml x86_64 5.3.3-23.el6_4 @updates 307 k
phpMyAdmin noarch 3.5.8.1-1.el6 @epel 18 M
Removing for dependencies:
owncloud noarch 5.0.12-12.1 @isv_ownCloud_community 47 M
owncloud-3rdparty noarch 5.0.12-12.1 @isv_ownCloud_community 1.6 M
Transaction Summary
================================================================================
Remove 18 Package(s)
Installed size: 85 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
Erasing : owncloud-3rdparty-5.0.12-12.1.noarch 1/18
Erasing : owncloud-5.0.12-12.1.noarch 2/18
Non-fatal POSTUN scriptlet failure in rpm package owncloud
Erasing : php-pear-MDB2-Driver-mysqli-1.5.0-0.8.b4.el6.noarch 3/18
警告: %postun(owncloud-5.0.12-12.1.noarch) scriptlet failed, exit status 1
Erasing : phpMyAdmin-3.5.8.1-1.el6.noarch 4/18
警告: /etc/phpMyAdmin/config.inc.php は /etc/phpMyAdmin/config.inc.php.rpmsave として保存されました。
警告: /etc/httpd/conf.d/phpMyAdmin.conf は /etc/httpd/conf.d/phpMyAdmin.conf.rpmsave として保存されました。
Erasing : php-pear-MDB2-2.5.0-0.9.b5.el6.noarch 5/18
Erasing : php-php-gettext-1.0.11-3.el6.noarch 6/18
Erasing : php-pear-Net-Curl-1.2.5-4.el6.noarch 7/18
Erasing : php-5.3.3-23.el6_4.x86_64 8/18
Erasing : php-mysql-5.3.3-23.el6_4.x86_64 9/18
Erasing : 1:php-pear-1.9.4-4.el6.noarch 10/18
Erasing : php-cli-5.3.3-23.el6_4.x86_64 11/18
Erasing : php-pdo-5.3.3-23.el6_4.x86_64 12/18
Erasing : php-mbstring-5.3.3-23.el6_4.x86_64 13/18
Erasing : php-gd-5.3.3-23.el6_4.x86_64 14/18
Erasing : php-mcrypt-5.3.3-1.el6.x86_64 15/18
Erasing : php-process-5.3.3-23.el6_4.x86_64 16/18
Erasing : php-xml-5.3.3-23.el6_4.x86_64 17/18
Erasing : php-common-5.3.3-23.el6_4.x86_64 18/18
警告: /etc/php.ini は /etc/php.ini.rpmsave として保存されました。
Verifying : 1:php-pear-1.9.4-4.el6.noarch 1/18
Verifying : php-xml-5.3.3-23.el6_4.x86_64 2/18
Verifying : php-common-5.3.3-23.el6_4.x86_64 3/18
Verifying : php-php-gettext-1.0.11-3.el6.noarch 4/18
Verifying : php-pdo-5.3.3-23.el6_4.x86_64 5/18
Verifying : php-mysql-5.3.3-23.el6_4.x86_64 6/18
Verifying : php-cli-5.3.3-23.el6_4.x86_64 7/18
Verifying : owncloud-5.0.12-12.1.noarch 8/18
Verifying : php-5.3.3-23.el6_4.x86_64 9/18
Verifying : php-mcrypt-5.3.3-1.el6.x86_64 10/18
Verifying : phpMyAdmin-3.5.8.1-1.el6.noarch 11/18
Verifying : php-pear-Net-Curl-1.2.5-4.el6.noarch 12/18
Verifying : php-pear-MDB2-Driver-mysqli-1.5.0-0.8.b4.el6.noarch 13/18
Verifying : php-mbstring-5.3.3-23.el6_4.x86_64 14/18
Verifying : php-pear-MDB2-2.5.0-0.9.b5.el6.noarch 15/18
Verifying : php-process-5.3.3-23.el6_4.x86_64 16/18
Verifying : php-gd-5.3.3-23.el6_4.x86_64 17/18
Verifying : owncloud-3rdparty-5.0.12-12.1.noarch 18/18
Removed:
php.x86_64 0:5.3.3-23.el6_4
php-cli.x86_64 0:5.3.3-23.el6_4
php-common.x86_64 0:5.3.3-23.el6_4
php-gd.x86_64 0:5.3.3-23.el6_4
php-mbstring.x86_64 0:5.3.3-23.el6_4
php-mcrypt.x86_64 0:5.3.3-1.el6
php-mysql.x86_64 0:5.3.3-23.el6_4
php-pdo.x86_64 0:5.3.3-23.el6_4
php-pear.noarch 1:1.9.4-4.el6
php-pear-MDB2.noarch 0:2.5.0-0.9.b5.el6
php-pear-MDB2-Driver-mysqli.noarch 0:1.5.0-0.8.b4.el6
php-pear-Net-Curl.noarch 0:1.2.5-4.el6
php-php-gettext.noarch 0:1.0.11-3.el6
php-process.x86_64 0:5.3.3-23.el6_4
php-xml.x86_64 0:5.3.3-23.el6_4
phpMyAdmin.noarch 0:3.5.8.1-1.el6
Dependency Removed:
owncloud.noarch 0:5.0.12-12.1 owncloud-3rdparty.noarch 0:5.0.12-12.1
Complete!
#消えてるか確認
$ rpm -qa |grep php
#なかったので入れなおしてみる。
$ sudo yum install php54 php54-php-gettext php54-pdo php54-mbstring php54-pear php54-process php54-common php54-cli php54-mysql php54-gd php54-pear-Net-Curl php54-pear-MDB2-Driver-mysqli php54-mcrypt phpMyAdmin php54-pear-MDB2 php54-xml
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
* base: ftp.nara.wide.ad.jp
* epel: ftp.kddilabs.jp
* extras: ftp.nara.wide.ad.jp
* ius: ftp.neowiz.com
* updates: ftp.nara.wide.ad.jp
Setting up Install Process
No package php54-php-gettext available.
No package php54-pear-Net-Curl available.
No package php54-pear-MDB2-Driver-mysqli available.
No package php54-pear-MDB2 available.
Resolving Dependencies
--> Running transaction check
---> Package php54.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-cli.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-common.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-gd.x86_64 0:5.4.19-1.ius.el6 will be installed
--> Processing Dependency: libt1.so.5()(64bit) for package: php54-gd-5.4.19-1.ius.el6.x86_64
---> Package php54-mbstring.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-mcrypt.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-mysql.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-pdo.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-pear.noarch 1:1.9.4-2.ius.el6 will be installed
---> Package php54-process.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package php54-xml.x86_64 0:5.4.19-1.ius.el6 will be installed
---> Package phpMyAdmin.noarch 0:3.5.8.1-1.el6 will be installed
--> Processing Dependency: php-php-gettext for package: phpMyAdmin-3.5.8.1-1.el6.noarch
--> Running transaction check
---> Package php-php-gettext.noarch 0:1.0.11-3.el6 will be installed
---> Package t1lib.x86_64 0:5.1.2-6.el6_2.1 will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
php54 x86_64 5.4.19-1.ius.el6 ius 2.7 M
php54-cli x86_64 5.4.19-1.ius.el6 ius 2.6 M
php54-common x86_64 5.4.19-1.ius.el6 ius 897 k
php54-gd x86_64 5.4.19-1.ius.el6 ius 116 k
php54-mbstring x86_64 5.4.19-1.ius.el6 ius 908 k
php54-mcrypt x86_64 5.4.19-1.ius.el6 ius 24 k
php54-mysql x86_64 5.4.19-1.ius.el6 ius 109 k
php54-pdo x86_64 5.4.19-1.ius.el6 ius 93 k
php54-pear noarch 1:1.9.4-2.ius.el6 ius 380 k
php54-process x86_64 5.4.19-1.ius.el6 ius 34 k
php54-xml x86_64 5.4.19-1.ius.el6 ius 144 k
phpMyAdmin noarch 3.5.8.1-1.el6 epel 4.3 M
Installing for dependencies:
php-php-gettext noarch 1.0.11-3.el6 epel 21 k
t1lib x86_64 5.1.2-6.el6_2.1 base 160 k
Transaction Summary
================================================================================
Install 14 Package(s)
Total download size: 12 M
Installed size: 49 M
Is this ok [y/N]: y
Downloading Packages:
(1/14): php-php-gettext-1.0.11-3.el6.noarch.rpm | 21 kB 00:00
(2/14): php54-5.4.19-1.ius.el6.x86_64.rpm | 2.7 MB 00:00
(3/14): php54-cli-5.4.19-1.ius.el6.x86_64.rpm | 2.6 MB 00:00
(4/14): php54-common-5.4.19-1.ius.el6.x86_64.rpm | 897 kB 00:00
(5/14): php54-gd-5.4.19-1.ius.el6.x86_64.rpm | 116 kB 00:00
(6/14): php54-mbstring-5.4.19-1.ius.el6.x86_64.rpm | 908 kB 00:00
(7/14): php54-mcrypt-5.4.19-1.ius.el6.x86_64.rpm | 24 kB 00:00
(8/14): php54-mysql-5.4.19-1.ius.el6.x86_64.rpm | 109 kB 00:01
(9/14): php54-pdo-5.4.19-1.ius.el6.x86_64.rpm | 93 kB 00:00
(10/14): php54-pear-1.9.4-2.ius.el6.noarch.rpm | 380 kB 00:00
(11/14): php54-process-5.4.19-1.ius.el6.x86_64.rpm | 34 kB 00:00
(12/14): php54-xml-5.4.19-1.ius.el6.x86_64.rpm | 144 kB 00:00
(13/14): phpMyAdmin-3.5.8.1-1.el6.noarch.rpm | 4.3 MB 00:00
(14/14): t1lib-5.1.2-6.el6_2.1.x86_64.rpm | 160 kB 00:00
--------------------------------------------------------------------------------
Total 1.5 MB/s | 12 MB 00:08
warning: rpmts_HdrFromFdno: Header V4 DSA/SHA1 Signature, key ID 9cd4953f: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/IUS-COMMUNITY-GPG-KEY
Importing GPG key 0x9CD4953F:
Userid : IUS Community Project
Package: ius-release-1.0-11.ius.el6.noarch (installed)
From : /etc/pki/rpm-gpg/IUS-COMMUNITY-GPG-KEY
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : php54-common-5.4.19-1.ius.el6.x86_64 1/14
Installing : php54-mbstring-5.4.19-1.ius.el6.x86_64 2/14
Installing : php54-cli-5.4.19-1.ius.el6.x86_64 3/14
Installing : php54-5.4.19-1.ius.el6.x86_64 4/14
Installing : php-php-gettext-1.0.11-3.el6.noarch 5/14
Installing : php54-mcrypt-5.4.19-1.ius.el6.x86_64 6/14
Installing : php54-pdo-5.4.19-1.ius.el6.x86_64 7/14
Installing : php54-mysql-5.4.19-1.ius.el6.x86_64 8/14
Installing : t1lib-5.1.2-6.el6_2.1.x86_64 9/14
Installing : php54-gd-5.4.19-1.ius.el6.x86_64 10/14
Installing : phpMyAdmin-3.5.8.1-1.el6.noarch 11/14
Installing : 1:php54-pear-1.9.4-2.ius.el6.noarch 12/14
Installing : php54-xml-5.4.19-1.ius.el6.x86_64 13/14
Installing : php54-process-5.4.19-1.ius.el6.x86_64 14/14
Verifying : t1lib-5.1.2-6.el6_2.1.x86_64 1/14
Verifying : php54-mbstring-5.4.19-1.ius.el6.x86_64 2/14
Verifying : php54-mysql-5.4.19-1.ius.el6.x86_64 3/14
Verifying : php-php-gettext-1.0.11-3.el6.noarch 4/14
Verifying : php54-5.4.19-1.ius.el6.x86_64 5/14
Verifying : php54-mcrypt-5.4.19-1.ius.el6.x86_64 6/14
Verifying : php54-xml-5.4.19-1.ius.el6.x86_64 7/14
Verifying : php54-common-5.4.19-1.ius.el6.x86_64 8/14
Verifying : 1:php54-pear-1.9.4-2.ius.el6.noarch 9/14
Verifying : phpMyAdmin-3.5.8.1-1.el6.noarch 10/14
Verifying : php54-process-5.4.19-1.ius.el6.x86_64 11/14
Verifying : php54-cli-5.4.19-1.ius.el6.x86_64 12/14
Verifying : php54-gd-5.4.19-1.ius.el6.x86_64 13/14
Verifying : php54-pdo-5.4.19-1.ius.el6.x86_64 14/14
Installed:
php54.x86_64 0:5.4.19-1.ius.el6
php54-cli.x86_64 0:5.4.19-1.ius.el6
php54-common.x86_64 0:5.4.19-1.ius.el6
php54-gd.x86_64 0:5.4.19-1.ius.el6
php54-mbstring.x86_64 0:5.4.19-1.ius.el6
php54-mcrypt.x86_64 0:5.4.19-1.ius.el6
php54-mysql.x86_64 0:5.4.19-1.ius.el6
php54-pdo.x86_64 0:5.4.19-1.ius.el6
php54-pear.noarch 1:1.9.4-2.ius.el6
php54-process.x86_64 0:5.4.19-1.ius.el6
php54-xml.x86_64 0:5.4.19-1.ius.el6
phpMyAdmin.noarch 0:3.5.8.1-1.el6
Dependency Installed:
php-php-gettext.noarch 0:1.0.11-3.el6 t1lib.x86_64 0:5.1.2-6.el6_2.1
Complete!
で一応見てみたところ
$ php -v
PHP 5.4.19 (cli) (built: Aug 23 2013 12:23:34)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
でこうしんされたね。
なんとなく気持ち的に
$ sudo /etc/init.d/httpd restart
[sudo] password for ryo:
httpd を停止中: [ OK ]
httpd を起動中: [ OK ]
Pocket

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です