EC2にphp5.4とかruby1.9とか…

Amazon Linuxで諸々古かったので、諸々インストールしてみた。

php5.4

$sudo yum remove php-* httpd-*
$sudo yum install httpd24 php54
$ php -v
PHP 5.4.17 (cli) (built: Jul 16 2013 23:21:13)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
# httpd がchkconfigに入ってなかったので
$ sudo chkconfig --add
$ sudo chkconfig |grep httpd
httpd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
※参考:http://higan96.hatenablog.com/entry/2013/02/14/195328
ruby 1.9
$ sudo yum install ruby19 ruby19-devel
$ sudo rm /usr/bin/ruby
$ sudo rm /usr/bin/gem
$ sudo ln -s /usr/bin/ruby1.9 /usr/bin/ruby
$ sudo ln -s /usr/bin/gem1.9 /usr/bin/gem
jsonを入れようとしたらgccが入っていなかったので
$ sudo yum install gcc
$ sudo gem install json --no-ri --no-rdoc
今度はAWS-SDKをインストールしようとしたら、nokogiriがないって言われたので
$ sudo yum install libxml2 libxml2-devel libxslt libxslt-devel
$ sudo gem install nokogiri
$ sudo gem install aws-sdk
とりあえずこれでOKっぽい。
Pocket

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です